Project

General

Profile

Bug #140

avatar jumping/standing up broken

Added by Josip Almasi 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Start date:
06/24/2022
Due date:
% Done:

0%

Estimated time:

Description

So instead of https://www.youtube.com/watch?v=05Tmra7nSTY&t=45s
we get either https://youtu.be/SOf_E60BSlI
or https://youtu.be/-0N73s6nAiU
depending whether these are commented out or not: https://github.com/jalmasi/vrspace/commit/3cb7ac2d0f4b2a65e17932b7cfabdaa0172341ee

Avatar.trackHeight() tracks user real world height in XR (it's set up in avatar-selection.js). It's a hack alright, but looks like either Avatar.standUp() or Avatar.jump() is malfunctioning.
It may be neither, as the code is simply not properly maintained, but it's likely as we have other issues that are likely related.

So we need a testbed first, that's going to make the issue reproducible outside of XR, and possible to debug.
We need either a button or a 3d object in avatar-test.html that's going to route height changes to trackHeight() and make character jump.


Related issues

Related to Bug #139: bjs5: when looking down or sitting, avatar does not standup againClosed06/22/2022

Actions

History

#1

Updated by Josip Almasi 3 months ago

  • Related to Bug #139: bjs5: when looking down or sitting, avatar does not standup again added
#2

Updated by Vander Dias 3 months ago

  • Status changed from New to Resolved
  • Assignee set to Vander Dias

Lol, debugging is sometimes embarrassing. Hours checking things to discover that it was just the threshold too high.

...
} else if ( height > this.maxUserHeight && Math.abs(speed) > 0.1 ) {
...

It was just a simple adjustment on the speed threshold and it is working again...

Also available in: Atom PDF